Receiving a red banner on the DLP Enforce interface stating "The Maximum number of active troubleshooting tasks (1000) has been reached. Try again later."
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Receiving a red banner on the DLP Enforce interface stating "The Maximum number of active troubleshooting tasks (1000) has been reached. Try again later."

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Article ID: 275487

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Updated On: 10-30-2024

Products

Data Loss Prevention Core Package

Issue/Introduction

You received a red banner limiting you to 1000 tasks. 

Environment

Release : ALL Versions

Cause

1000 is the default "out-of-the-box" limitation.

Resolution

In order to increase this limit, there are 2 settings you will need to adjust in the "Manager.properties" file located on the Enforce server. 

 

   Default location for "Manager.properties" file:

 

   WIndows: C:\Program Files\Symantec\DataLossPrevention\EnforceServer\<version>\Protect\config


   Linux: /opt/Symantec/DataLossPrevention/EnforceServer/<version>/Protect/config

 

Once on the Enforce server, you will need to edit the Manager.properties file. 

 

Prior to making any changes, it is recommended that you make a copy backup of the file. If there are any issues, restore the backup and restart services

 

Instructions: .

 

You will find both settings in the "Manager.properties" file: 

# The maximum number of Agent troubleshooting tasks that can be executing at a time.
# com.vontu.manager.troubleshootingTask.maxTotalActiveTasks = 1000

AND

# The max number of active tasks of type CHANGE_SERVER_LIST
# com.vontu.manager.troubleshootingTask.maxTasks.CHANGE_SERVER_LIST = 1000

Example of un-edited file:

 

You will need to Un-comment the second line of each setting, and change the number value from 1000 to your new value. 

For example, if you are changing it to 5000, it will look like this: 

Once change is completed, restart Enforce services for the changes to take effect. 

Note: Increasing this setting above the default may cause performance issues in the Enforce console.