UIM Connector is down.
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UIM Connector is down.

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Article ID: 275345

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Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

We need your urgent support as UIM connector is down after doing monthly windows update.

Environment

SOI 4.2.0.551.201221
catalyst connector 3.4.40
UIM 20.48

SQLServer 5.20 and later

Cause

UIM Connector sending lot of Ci's to SOI

Resolution

Follow the below Step:-

== Deactivate the sqlserver probe.
== Delete the alarms.cfg file from the CA UIM Installation Directory > probes > Database > sqlserver folder.
== Upgrade the SQLServer probe to latest version
==  open the probe Raw Configure interface. Go to the setup  section, and set the usm_display_db_level key to 1. When you enable this key, the CI name is appended with Database Instance Name. If no    database name is mentioned in the CI for a profile checkpoint, the probe adds the master database name in the defined format.
 
Default: 0
== Clear the niscache folder of all the robots in your environment that have the sqlserver probe.
== Acknowledge all alarms from the probe.
== Run the following queries on your UIM database to delete the QoS data from the probe:
 
delete from s_qos_data where probe = 'sqlserver'
 
delete from s_qos_definition where qos_group = 'QoS_SQLSERVER'
 
delete from nas_alarms where prid = 'sqlserver'
 
delete from cm_configuration_item_metric where ci_metric_type like '4.2%'
 
delete from cm_configuration_item where ci_type like '4.2%'
== Restart the data_engine, nas, nis_server, discovery_server, and discovery_agent probes.