Agent on the SMP Server unable to get policies. COM error: The server is currently too busy to process the request (0x8004200C)
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Agent on the SMP Server unable to get policies. COM error: The server is currently too busy to process the request (0x8004200C)

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Article ID: 275267

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Updated On:

Products

IT Management Suite

Issue/Introduction

The customer recently upgraded to ITMS 8.7.1 release. After that, he started noticing that the Symantec Management Agent on the SMP Server itself was not getting configuration and sending basic inventory.

The following agent log entries are present:

Entry 1:

[1DE42570020, WS: 720] Failed to send SMP frame '{32FB5E6D-4E8B-4965-9E4F-9642A99A95E6}', ID: {387D322E-59C8-4CDE-BBDD-7EFBA845809B}, timeout: 120 seconds, error: This operation returned because the timeout period expired (0x000005B4)
-----------------------------------------------------------------------------------------------------
Date: 10/20/2023 1:30:53 PM, Tick Count: 1211166406 (14.00:26:06.4060000), Size: 478 B
Process: AeXNSAgent.exe (8784), Thread ID: 9244, Module: AeXNetComms.dll
Priority: 2, Source: SMAIO.WSTransport.COM

 

Entry 2:

Policy request failed, COM error: The server is currently too busy to process the request (0x8004200C)
-----------------------------------------------------------------------------------------------------
Date: 10/20/2023 1:30:53 PM, Tick Count: 1211166406 (14.00:26:06.4060000), Size: 336 B
Process: AeXNSAgent.exe (8784), Thread ID: 9244, Module: AeXNSAgent.exe
Priority: 1, Source: ConfigServer

 

The customer is using persistent connections but even when it is disabled, the same issue remains.
IIS has been restarted and Altiris Service as well.

Environment

ITMS 8.7.1

Cause

Known issue. Apparently, policy request is looking for virtual machine by resource keys but for some reason this resourcetype is physical, therefore resource is not found.
A minimal Symantec.AgentActions assembly change was needed, that will allow Web Socket engine to handle error correctly.

Resolution

This issue has been reported to our Broadcom Development team. A fix is planned for our ITMS 8.7.2 Release.

A pointfix is available for 8.7.1:

KB 261271 "CUMULATIVE POST ITMS 8.7 RTM POINT FIXES"  
https://knowledge.broadcom.com/external/article?articleId=261271

KB 273903 "CUMULATIVE POST ITMS 8.7.1 POINT FIXES"
https://knowledge.broadcom.com/external/article?articleId=273903