After applying the CP2 on top of IM 14.4 the JBoss/Wildfly Fails To Start
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After applying the CP2 on top of IM 14.4 the JBoss/Wildfly Fails To Start

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Article ID: 275223

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Updated On:

Products

CA Identity Suite CA Identity Manager

Issue/Introduction

After applying the CP2 on top of IM 14.4 the JBoss/Wildfly Fails To Start and the server log shows an error and exception stack such as:

YYYY-MM-DD HH:MM:SS,680 ERROR [ims.Main] (ServerService Thread Pool -- 94) java.lang.SecurityException: PBOX00016: Access denied: authentication failed
 at org.jboss.security.plugins.JBossSecuritySubjectFactory.createSubject(JBossSecuritySubjectFactory.java:92)

Caused by: javax.security.auth.login.LoginException: java.lang.NoClassDefFoundError: org/apache/logging/log4j/core/appender/ConsoleAppender$Target
 at com.netegrity.jboss.datasource.PicketBoxPasswordEncryptedLogin.commit(PicketBoxPasswordEncryptedLogin.java:81)

Caused by: java.lang.ClassNotFoundException: org.apache.logging.log4j.core.appender.ConsoleAppender$Target from [Module "com.ca.iam.idmutils" from local module loader @3eba57a7 (finder: local module finder @272a179c (roots: /jboss/modules,/jboss/modules/system/layers/base/.overlays/layer-base-jboss-eap-7.2.9.CP,/jboss/modules/system/layers/base))]
 at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:255)

 

Environment

Release : 14.4

Cause

Something during the original IM 14.4 upgrade did not get handled properly and the JBoss/Wildfly modules folder was not properly upgraded to 14.4 and so applying the CP2 on top of that modules folder has caused a conflict.

For example in the above mentioned error the problem is that the JBoss/Wildfly has a \modules\com\ca\iam\idmutils\main\module.xml file which is still referencing log4j instead of log4j2

But there could be other problems with the modules folder such as the \modules\com\ca\iam\crypto\main\module.xml not containing the reference to the sun security provider or missing the \modules\javax\ws\rs\api\main related files too for instance.

Resolution

Open a new support case and provide the IM Server log capturing the start up sequence and error along with a zip/tar of the JBoss/Wildfly modules folder for review.