Save Results as Filter Button Creates Filter Using vAC_ComputerLicenseAndUsageByProduct Causing High Overhead
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Save Results as Filter Button Creates Filter Using vAC_ComputerLicenseAndUsageByProduct Causing High Overhead

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Article ID: 275178

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Updated On:

Products

Client Management Suite

Issue/Introduction

On the SMP Console, go to Manage Software, then:

  • You click on Installed Products
  • You find a product that you want to make into a filter and select it
  • You click on the icon to save results as a filter and give the filter a name

Then View the new filter and notice it's using SQL logic, for example:   SELECT c.ResourceGuid FROM vAC_ComputerLicenseAndUsageByProduct c WHERE  c.SoftwareProductGuid in ('b76ee4a0-3031-43ac-b81a-41700dd17aaa') 

Since the filter utilizes the vAC_ComputerLicenseAndUsageByProduct SQL View, it creates an unnecessary overhead when loading the filter's membership or during filter membership updates.

Environment

ITMS 8.7.1

Cause

The vAC_ComputerLicenseAndUsageByProduct view is the problem.

Resolution

This was fixed in the ITMS 8.7.2 release.

Filter creations, using the default filter by usage drop-down, will now create the filter using faster performing SQL logic:

However, if using non-default filter by usage logic, then the filter creation will still use the vAC_ComputerLicenseAndUsageByProduct view:

Additional Information

IT Management Suite 8.7.2 Release Notes - Fixed Issues

  • Filter created using Save Results as Filter option may causes resources overhead.