Database table is marked as crashed and does not repair
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Database table is marked as crashed and does not repair

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Article ID: 275160

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Updated On:

Products

Messaging Gateway

Issue/Introduction

You have noticed that you are seeing continual log entries that a table has crashed and failed to repair, similar to the following entries:

brightmail.report_message
error    : Can't create new tempfile: './brightmail/report_message.TMD'
status   : Operation failed

and 

brightmail.report_message
Error    : Table './brightmail/report_message' is marked as crashed and last (automatic?) repair failed
Error    : Table 'report_message' is marked as crashed and last (automatic?) repair failed
error    : Corrupt

The corrupted table may interfere with different functions of the Control Center.

Environment

Release : 10.8.0

Cause

The referenced database table has become corrupt and cannot be repaired.

Resolution

To resolve this issue you will need to reset the Control Center using the following command:

  • delete bccdata

The "delete bccdata" command  rebuilds the database and tables. Since resetting the Control Center means a loss of data, you will need to make sure you have a current backup before resetting the Control Center, so it can be restored directly after reset. It would be best if this backup was also stored separate from the Control Center as a precaution.

The resetting of the Control Center will provide the following warning:

$ delete bccdata
WARNING: Using ctrl-c to interrupt this program may corrupt your settings.
WARNING: You are about to delete the following:

        * SPC data
        * control center HTTPS certificate from keystore
        * control center data

Your appliance will reboot following deletion.
WARNING: You will need to re-register the Control Center with your SPC server
after clearing the SPC-related data
WARNING: You will need to rerun the Site Setup Wizard after clearing the
Control Center configuration

Delete? (You must type 'yes' to confirm):

As it says in the warning, the Control Center data will be deleted. You will need to run the Site Setup wizard again, which includes the following tasks:

After you complete the Site Setup Wizard and have access to the Control Center, restore the database backup to fully complete the reset.

Once your backup has been restored and your Control Center is fully operational again, the database table errors should cease and related issues should also cease.