A2A Client error, "Stopping Acceptor ServerSocket"
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A2A Client error, "Stopping Acceptor ServerSocket"

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Article ID: 275029

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

The A2A Client is returning error 445 whenever trying to pull credential.

A2A Client logs:

INFO: Sat August 12 01:17:41.033 EDT 2023 ScriptService::doGet. errorCode: 400, accountId: ClientTest, password: XXXXXXXXXXXXXXXXXX, XML block length: 4
Aug 12, 2023 1:25:16 AM org.mortbay.util.ThreadedServer$Acceptor run
INFO: Stopping Acceptor ServerSocket[addr=0.0.0.0/0.0.0.0,port=0,localport=28888]======================>
Aug 12, 2023 1:25:16 AM org.mortbay.http.SocketListener stop
INFO: Stopped SocketListener on 0.0.0.0:28888===================================>
Aug 14, 2023 6:57:56 AM org.mortbay.util.LogSupport <clinit>
INFO: Log instance is class org.apache.commons.logging.impl.Jdk14Logger
Aug 14, 2023 6:57:56 AM org.mortbay.http.HttpServer start
INFO: Starting Jetty/5.0.alpha2

Environment

PAM: 4.1

Any A2A Client version

Cause

 The JRE could not establish the https connection to the PAM server because of a problem with the /var/tmp file system.

This issue is causing JRE to hang trying to use /var/tmp while looking for the configured cipher suites on the server. 

Resolution

To resolve this issue: 

1. Make sure that /var/tmp on the server which A2A client is configured is performing well to any commands run, such as "ls -l /var/tmp".

2. Restart A2A Client service

3. The main suggestion is to reboot the server.