Getting NULL value in Ktd_duration of database
search cancel

Getting NULL value in Ktd_duration of database

book

Article ID: 274904

calendar_today

Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

ktd_duration,ktd_duration_wshft,workshift  from usp_kpi_ticket_data are not being updated.

We are getting Null value in ktd_duration of usp_kpi_ticket table.

 

Environment

Release : 17.3

Cause

KPI Daemon in hung state.
<Servername> kpi_qry_daemon          8024 SIGNIFICANT  cal_duration.c         331 Start KPI duration calculation failed. Already in prog

Resolution

Workarround: 
Steps : 
Stop SDM services. 
Edit NX.ENV 
 From : @NX_KPI_TICKET_DATA_TABLE_DELAY=300
 To:       @NX_KPI_TICKET_DATA_TABLE_DELAY=600
 Start SDM services 

Additional Information

Reference article to capture window debug diag crash dump if KPI Daemon is Crashing / Hanging. 
https://knowledge.broadcom.com/external/article/20303/working-with-broadcom-support-to-trouble.html