Message "PAM-AGT-1100: Service activation failed. Please restart the PAM Agent and the PAM Agent service and try again" when activating a service in CA PAM Agent
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Message "PAM-AGT-1100: Service activation failed. Please restart the PAM Agent and the PAM Agent service and try again" when activating a service in CA PAM Agent

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Article ID: 274741

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

Trying to use CA PAM Agent to manage TCP a service for an endpoint  in CA PAM Agent, this is not possible as every time the following error appears

PAM-AGT-1100: Service activation failed. Please restart the PAM Agent and the PAM Agent service and try again

 

Environment

CA PAM all versions as of 4.1.5

Cause

There may be multiple causes for this error, but a common one is that the PAM agent was not able to connect to the endpoint we are trying to add via RPC

In this particular case the following lines will appear in the CAPAMAgentService.log

[2023-10-09 15:42:15.362] [17304] [error] HlprFwpmFilterAdd : FwpmFilterAdd() [status: 0x80320002]
[2023-10-09 15:42:15.363] [17304] [error] RPCInvokeScenarioProxy() [status: 0x80320002][pPCProxyData: 0x70abccd0]

While the CAPAMAgent.log will display the following corresponding messages

[2023-10-09 15:49:24.265] [23368] [error] CommonUtil::ResolveHostname(), calling getaddrinfo() for hostname [<servername>] failed.

Where <servername> is the FQDN of the server you are trying to enable the service for in the CA PAM Agent

What this log entry is indicating is that the <servername> server was unable to resolve to an ip address and therefore connection was not possible

Resolution

Make sure that <servername> is resolvable to its IP address from the machine running the CA PAM Agent and eventually make sure as well that the machine is available and started