CU9 upgrade fails around "Initializing ACL security for distsrv."
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CU9 upgrade fails around "Initializing ACL security for distsrv."

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Article ID: 274364

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Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

My CU9 upgrade has failed at the step "Initializing ACL security for distsrv"

The log located at C:\Windows\tmp\ca_uim\uimserver_ia_install.log shows the following error:

 - Waiting for distsrv probe to respond.
  - distsrv probe has not responded.
 - NimException caught (4) not found, Received status (4) on response (for sendRcv) for cmd = 'nametoip' name = '</domain/hub/robotname/distsrv>'

Environment

Release : 20.4 CU9

Cause

This issue was observed in an environment where the distsrv probe took more than 5 minutes to start up during the point in the installation where distsrv is restarted.

Resolution

- Cancel upgrade
- Rename folder ($NIMSOFT_HOME)/Nimsoft/archive/  to something like archive_old
- restart distsrv probe - new, empty Archive folder should be generated
- Try upgrade again
- Once the upgrade completes, move the files from archive_old back into the new archive folder and delete archive_old.  (It may be a good idea to clean up the archive at this point as well - it is likely that old versions of probes can be deleted if you already have newer versions of the same probe in the archive, for example.)