How do you get the True Type field in the SDK to be populated in an ICAP response
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How do you get the True Type field in the SDK to be populated in an ICAP response

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Article ID: 274346

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Updated On:

Products

Protection Engine for Cloud Services

Issue/Introduction

ICAP responses using the Symantec Protection Engine's (SPE) SDK, or responses to file submissions to the SPE via the RestAPI, always list a file's "True Type" as "NA".

Environment

Release : 8.2.x, 9.x

Cause

An undocumented setting (EnableFileTrueTypeInICAPResponse) is not set.

Resolution

NOTE: The following steps may cause a performance hit to CPU and it is therefore recommended that you monitor the SPE's resources after following these steps:

  1. Download a copy of the category3.xml that is attached to this article
  2. Copy the category3.xml to the Scan Engine folder:
    • For Linux the default Scan Engine folder is:
      /opt/SYMCScan/bin
    • For Windows the default Scan Engine folder is:
      C:\Program Files\Symantec\Scan Engine
  3. Restart the SPE

Attachments

1695921173059__category3.xml get_app