Data partition constraints are not working for Knowledge Documents
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Data partition constraints are not working for Knowledge Documents

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Article ID: 274273

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Updated On:

Products

CA Service Desk Manager

Issue/Introduction

After RU22 deployment CASM Version: 17.3,  data partition constraints are not working properly

Steps to reproduce:

 Create a Data Constraint for the Service Desk Analyst and also Employee with Table: O_Comment, Type: Create, Constraint: id = 0 and Error Message: Can't create a comment

Test A: Using Employee Role, with Service Point and Employee Classic interface, access the KDoc and add a Comment. A constraint message will appear for both interfaces saying that you are not allowed.

On Service Point: error - Failed to add KBArticle comment (Not the correct message)

On Classic Interface: the comment is added, no constraint message will appear, and notifications are fired if exists.

Test B: Using Level 2 Analyst Role, with Xflow and Analyst Classic Interface, access the KDoc and add a Comment.

On both interfaces, the comment is added, no constraint message will appear, and notifications are fired if exists.

Seems that create data partition constraints is not working properly, except to the Service Point where the constraint message is not the correct one.

 

Environment

Release: 17.3 +

Cause

The root cause of the issue discovered to be that the comments were added as a superuser, and were ignoring the data partitions. 

Resolution

 Code fix to enhance the Classic, xFlow, and Service Point UIs was tested and included with RU23