PAM Appliance Does Not Reboot When Applying a Patch
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PAM Appliance Does Not Reboot When Applying a Patch

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Article ID: 274211

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

When applying a patch, the user is kicked out of the GUI almost immediately after hitting the prompt to reboot the appliance. When the user logs back in, the patch had not been applied.

Environment

Privileged Access Manager, versions 4.0.x and 4.1.0-4.1.4

Cause

When a patch is applied, PAM first runs a system sync command. Once the system sync is complete, it then stops all services and issues the reboot command last. In this case, the system sync command never completed, preventing the reboot from happening.

Resolution

Open a Support case so an engineer can SSH into the appliance and reboot it through the command line. Once the reboot occurs, the upgrade script will kick off and apply the patch.

 

Additional Information

SE has reviewed the code and will make improvements to this process for the 4.1.5 and 4.2.0 releases.