SQL Server Connection issues in CA TDM Portal post upgrade
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SQL Server Connection issues in CA TDM Portal post upgrade

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Article ID: 274206

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Updated On:

Products

CA Test Data Manager (Data Finder / Grid Tools)

Issue/Introduction

We upgrade TDM Portal to 4.10.219.0, but we are getting an error for all our SQL Server connection profiles in TDM Portal.

Error: The server replied: Failed to obtain JDBC Connection; Login failed for user 'AD1\XXXXXXXXX. ClientConnectionId:b7248727-nnnn-4654-nnnn-1708nn5n66nn

We tried reverting to the TDM 4.10 GA build, which was working before the upgrade, and the connections are failing for this release as well. We are trying to connect to SQL Server 2016 with Integrated Security.

 

 

Environment

Release : TDM Portal 4.10.xxx or newer

Cause

After upgrading the TDM Portal, the "CA Test Data Manager Portal" Windows service is rebuilt, which causes the service to configured to start under the Local System Account.

Since the TDM Services are now running as the Local System, and not the proper service account, the connections used for the integrated security to the SQL Server connections are failing.

Resolution

If your implementation of the "CA Test Data Manager Portal" Windows service should be running under a service account, you will need to:

  1. Stop the CA Test Data Manager Portal service
  2. Right-click on CA Test Data Manager Portal service, and select Properties
  3. In the Properties dialog window, select the Log On tab
  4. Modify the properties to run the service under the appropriate service account
  5. Select OK, and close the dialog window.
  6. Restart the CA Test Data Manager Portal service.