Importing computers from a CSV file is creating Duplicate records after the agent is installed
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Importing computers from a CSV file is creating Duplicate records after the agent is installed

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Article ID: 274194

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Updated On:

Products

Client Management Suite IT Management Suite

Issue/Introduction

We have an import rule that creates the new resource if it doesn't exist in Altiris. This is creating new records for computers not in the CMDB.

Then we install the Agent on the computer that we've imported.  The installation is successful, but when the Symantec Management Agent is installed, it creates a duplicate computer instead of reusing the record previously created. 

How can we import computers from CSV and avoid creating a duplicate computer resource?

 

Environment

8.x

Cause

When importing with Resource lookup key set to 'Resource Name', there is not enough information to create the necessary resource keys to prevent a duplicate record being created when the agent is installed.

Resolution

Change the Resource Look Up Key to Computer Name / Domain, then enough resource keys are added so that when the agent is installed, there is no duplicate created. 

Column Mappings look like this:

It is necessary to delete any existing records from previous imports, and reimport the data using this method.  Simply changing the rule will not update the records that have already been created.