Workflow Dynamic Resolver to User Custom Field Approval assignment cannot extract approving users from a user custom field where approvers are registered separated by comma
search cancel

Workflow Dynamic Resolver to User Custom Field Approval assignment cannot extract approving users from a user custom field where approvers are registered separated by comma

book

Article ID: 274142

calendar_today

Updated On: 03-17-2025

Products

CA Identity Suite

Issue/Introduction

When performing a dynamic participant resolver in the task to search in the User's customfield by the list of approvers, contains more than one loginID, separated by commas, when the task is executed it cannot find the approver and passes the Workflow to to a rejected state.

When it contains a single approver loginID it works correctly.

 

Environment

Release : 14.5

Cause

The dynamic resolver function does not understand the comma character in a user custom field as a separator.

Resolution

1. Change the Screen attribute from Text to Multi-Text
2. When doing by gui to add new users in the field use the muti-text to have each user in a different line.
3. When modifying the user by tews use a pipe (|) character to separate each user in the multi-text field.