User authentication fails after policy server upgrade
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User authentication fails after policy server upgrade

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Article ID: 274082

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Updated On:

Products

SITEMINDER CA Single Sign On Secure Proxy Server (SiteMinder) CA Single Sign On Agents (SiteMinder)

Issue/Introduction

Test user is unable to authenticate to an LDAP user store  There are no apparent errors logged.

Environment

Release : 12.8.07

Cause

The web agent trace log showed that the user was failing authentication on the policy server.  The policy server trace log showed a failed authentication attempt.  When the policy server uses the word attempt, it indicates the user was not found in the directory.  Also in the trace log we could see that the policy server was attempting to find the user via the LoginAlias attribute rather than UID.  Upon checking the directory, no LoginAlias attribute existed for the test user.  This was due to a data migration that occurred at the same time as the policy server upgrade.

Resolution

Modifying the User Lookup string in the user store properties to use UID allowed the user to log in.