Service Specific Error 651 Starting the XCOMD XCOM Scheduler Service
book
Article ID: 27408
calendar_today
Updated On:
Products
XCOM Data Transport - Windows
Issue/Introduction
After performing a "typical" install, the XCOMD XCOM Scheduler Service may not start and the following error message may be displayed:
Service specific error code 651
Environment
XCOM™ Data Transport® for Windows
Cause
A typical install for XCOM will install both SNA and TCPIP support. When XCOMD starts, XCOM expects SNA to be available and working. When it is not, XCOM displays service specific error code 651.
Resolution
The solution to this is to remove any SNA information from the XCOM configuration files.
In \xcomnt\config\xcom.glb, change PROTOCOL=SNA to PROTOCOL=TCPIP. This path may differ depending on where you installed XCOM.
Also in xcom.glb, set TP_CMD= (there should be nothing on the line after the = until the end of the line). Do not comment out TP_CMD.
Also make sure the \xcomnt\xcom.cnf file or any other .cnf files specify PROTOCOL=TCPIP.