network error dwnloading files from “go.microsoft.com” with WSS Agent
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network error dwnloading files from “go.microsoft.com” with WSS Agent

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Article ID: 274054

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Updated On:

Products

Cloud Secure Web Gateway - Cloud SWG

Issue/Introduction

Users access internet via CLoud SWG using WSS Agent.

Certain users try to download files on URL below from Chrome running in the system and not user context. This psexec command was used to launch chrome in system context:

.\psexec.exe -s -i "C:\Program Files\Google\Chrome\Application\chrome.exe"

Running Chrome in standard user mode downloads the file successfully.

The download does appear to start but stops immediately with the network error shown below:

 

 

Environment

WSS Agent.

Cause

Issues with older versions of Chrome running in the system context.

Resolution

Upgrade to newer version of Chrome, or try another browser.

Additional Information

The HAR file showed that the response to the download request is valid (200 OK with a 136MB file), which explains why the download started.

HTTP/1.1 200 OK
Content-Type: application/octet-stream
Server: Windows-Azure-Blob/1.0 Microsoft-HTTPAPI/2.0
x-ms-request-id: 801e-003e-4e01-000000
x-ms-version: 2009-09-19
x-ms-lease-status: unlocked
x-ms-blob-type: BlockBlob
Last-Modified: Tue, 22 Aug 2023 07:03:19 GMT
ETag: 0x8DBA2DDDDFE
Content-Length: 136054360
Date: Tue, 22 Aug 2023 14:11:29 GMT
Connection: keep-alive
 

The corresponding PCAP from Symdiag however shows that the client sends a TCP FIN very soon after the download starts.

We then tested with another browser (Edge) running in the system context and this worked fine.

Looking at the Chrome versions in more detail, it was running a very old (99) version. After upgrading to the 116 version, the problem went away.