Got "The private key of ESPREST KEYA is not available or no authority to access the private key" when starting Agent Manager
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Got "The private key of ESPREST KEYA is not available or no authority to access the private key" when starting Agent Manager

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Article ID: 273839

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Updated On:

Products

ESP Workload Automation

Issue/Introduction

Working on starting the Agent Manager and are receiving the following error:
Failed to start bean 'webServerStartStop'; nested exception is org.springframework.boot.web.server.WebServerException: Unable to start embedded Tomcat server

Also found errors below in the STC log:
ICH408I USER(USERA ) GROUP(BBBB) NAME(YYYYY,XXXX   ) 
IRR.DIGTCERT.GENCERT CL(FACILITY) 
INSUFFICIENT ACCESS AUTHORITY 
 ACCESS INTENT(CONTROL)  ACCESS ALLOWED(NONE   ) 

Related java error:
Caused by: java.lang.IllegalArgumentException: The private key of ESPREST KEYA is not available or no authority to access the private key


 

 

Environment

Release : 12.0
Component: Agent Manager

Cause

The WAM STC ran as a JOB under a non-STC ID. 

Resolution

The WAM STC should run as a STC with proper user ID.


Additional Information

Note: The WAM database needs to be deleted as it's created by the wrong user and the proper STC user can't access it. This can prevent "Add scheduler" function.