Unable to upload and download attachment files intermittently.
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Unable to upload and download attachment files intermittently.

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Article ID: 273808

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Updated On:

Products

CA Service Management - Service Desk Manager

Issue/Introduction

When uploading a file to a ticket, the following error message is displayed and upload fails. End users cannot download attachment files either. 

Failed to upload file 'memo.txt': Could not get a repository session. The file was not uploaded.

The problem is resolved after restarting the Tomcat service, but it starts to happen after a while. 

The stdlog.x shows the following error messages.

e.g.
09/13 20:25:02.42 SDMSRV rep_daemon              5460 ERROR        AttmntMng.c            512 OpenSession() - Failed to get last repository folder for: \\FILESV/REPOSITORY/GENERAL (No such file or directory (2))
09/13 20:25:02.42 SDMSRV rep_daemon              5460 ERROR        DomWrap.c              959 Failed to complete reply method: 'MTH::validate_bopsid_done' ,BOP Name:'Attachment id:14200305' in class:'CDownloadFile', Error:AHD04012: security id (527914789) not found or has expired

Environment

Release : 17.3

Cause

Too many files are stored in the Repository. 

Resolution

Create a new repository and use it for a default repository for end users.

Additional Information

AHD05949 error during attempts to upload attachments

Cannot view or upload attachments in Service Desk Manager.

Service Desk Attachment for download and upload anymore. Getting error AHD05949 Unable to acquire a repository session. File not uploaded