Unable to login to CA Service Point mobile application
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Unable to login to CA Service Point mobile application

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Article ID: 273309

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

After entering the credentials to log into the SP Mobile App, the app just closes/crashes so the users cannot login

The following error appears in the IncidentMS_debug.log:

[c.c.c.a.AuthenticationInterceptor] - Header name [X-Requested-With], Header value [com.ca.casmmobileapp]
[c.c.c.a.AuthenticationInterceptor] - The logon attempt failed
com.sun.jna.platform.win32.Win32Exception: The logon attempt failed
 at waffle.windows.auth.impl.WindowsAuthProviderImpl.acceptSecurityToken(Unknown Source)
 at com.ca.casm.authentication.AuthenticationInterceptor.getSecurityContext(AuthenticationInterceptor.java:903)
 at com.ca.casm.authentication.AuthenticationInterceptor$1.call(AuthenticationInterceptor.java:367)
 at com.ca.casm.authentication.AuthenticationInterceptor$1.call(AuthenticationInterceptor.java:119)
 at play.core.j.JavaAction.$anonfun$apply$8(JavaAction.scala:175)
 
 
If we open a browser on the same mobile device, the popup window appears, credentials are accepted, and can log into the xFlow/Service Point Web Application. 

Environment

Release: 17.3 RU 21

NTLM and HTTPS are enabled on xFlow/Service Point

Wildcard certificate

Android and iOS

Cause

Defect with 17.3 RU 21

Resolution

Upgrade to the latest mobile app and upgrade SDM/xFlow to 17.4 or 17.3 RU23