[SOI] Alert cleared in SOI are not cleared in SCOM/Spectrum (Sync not working)
search cancel

[SOI] Alert cleared in SOI are not cleared in SCOM/Spectrum (Sync not working)

book

Article ID: 273304

calendar_today

Updated On:

Products

CA Service Operations Insight (SOI)

Issue/Introduction

The alert (back) synchronization between SOI and SCOM/Spectrum stopped working. Alerts, which are cleared in SOI are not cleared in SCOM/Spectrum anymore. 

Environment

Release : 4.2

Cause


We analyzed the configuration for the alert sync option and noticed the following for the registryloader.bat :

If plannerControlFileURL contains dropall.xml then it means it will disable the alert sync option after running registryloader.

If plannerControlFileURL contains alert_filter.xml it means it will enable the alert sync option after running registryloader.

Resolution

Open the below file and modify it accordingly -

CA\SOI\tomcat\registry\topology\physical\node0\sor\sorapp.xml 

Verify the below line with plannerAlertPolicy– 

<tns:plannerPolicy inj:injID="plannerAlertPolicy">

      <tns:persistenceManager inj:injRef="pm"/>

      <tns:queryManager inj:injRef="qm"/>

      <tns:type>Alert</tns:type>

      <tns:handledProperty>IsAcknowledged</tns:handledProperty>

      <tns:handledProperty>IsCleared</tns:handledProperty>

      <tns:plannerFilterPolicy inj:injID="alertFilter">

        <tns:plannerControlFileURL>registry:///topology/physical/node0/sor/syncfilters/dropall.xml</tns:plannerControlFileURL> // Disable sync option

                                                                    OR

       <tns:plannerControlFileURL>registry:///topology/physical/node0/sor/syncfilters/alert_filter.xml</tns:plannerControlFileURL> // Enable sync option

      </tns:plannerFilterPolicy>

    </tns:plannerPolicy>