Removing the 4x Agent Flag on a Siteminder Web Agent.
search cancel

Removing the 4x Agent Flag on a Siteminder Web Agent.

book

Article ID: 273278

calendar_today

Updated On:

Products

SITEMINDER

Issue/Introduction

When you initially create an Agent object using the Siteminder AdminUI,  you have the choice to set the "Supports 4x Agents" flag on the agent.

Once an Agent object is created, you can later modify the Agent and enable the "Supports 4x Agents" flag on that Agent.

However, after setting the "Supports 4x Agents" flag on the Agent and saving it, the  "Supports 4x Agents" feature cannot able to be disabled. 

 

Environment

PRODUCT: Siteminder

COMPONENT: AdminUI

VERSION: ANY

OS: ANY

Cause

Once a web agent has been configured to support 4x agents, it cannot be set back.  This agent will support both 4x and 5x agents with the 'supports 4x agents' flag set.

Resolution

To disable the "Supports 4x Agents" flag from an Agent object, you would need to do the following:

1) Create a temporary web agent "TempAgent".

2) Assign the "TempAgent" to all the realms where the original agent was assigned.

3) Delete the original 4x Agent object in either the AdminUI or XPSExplorer.

4) Create the original Agent object again without selecting "Supports 4x Agents".

5) Reassign the new Agent object to all the Realms that have "TempAgent" assigned.

6) Delete "TempAgent"