Protection Engine Service is not starting if running with custom user
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Protection Engine Service is not starting if running with custom user

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Article ID: 273179

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Updated On:

Products

Protection Engine for NAS

Issue/Introduction

The Symantec Protection Engine (SPE) service is not getting started if the SPE service is running with a custom user 

While starting the SPE service you can see the error "The Symantec Protection Engine service on the Local computer started then stopped".

In Windows Application Events you may see following error 
Date    Log    Event Type    Source    Computer    User    Event ID    Description    Details 8/31/2023 5:23:34 PM    Application    Error    Application Error    <Custom user details>        1000    "Faulting application name: symcscan.exe, version: 9.0.0.49, time stamp: 0x640b6917 Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000 Exception code: 0xc Fault offset: 0x0 Faulting process id: 0xfd4 Faulting application start time: 0x0 Faulting application path: D:\Program Files\Symantec\Scan Engine\symcscan.exe Faulting module path: unknown Report Id: 2 Faulting package full name:  Faulting package-relative application ID:"       SymantecProtectionEngineAbortLog.txt   2023/08/25-17:47:40 1600 Aborting with unknown message ID : Failed to start REST API service. 2023/08/25-17:47:40 0 Symantec Protection Engine is shutting down; logs may contain more information.

 

Environment

Symantec Protection Engine 9.0 and Higher

Cause

To run SPE service with a user other than 'SYSTEM', the user needs to have the privileges same as the Administrator.

Resolution

Provide the Administrator Privileges to the custom user and start the SPE service.

  1. Open Start | Computer Management | Local Users and Groups (or run lusrmgr.msc)
  2. Double-click on the 'Administrators' group
  3. Click the 'Add...' button
  4. Provide the service account details