DLP agent temp folder is filling up with .Vep files on machines that use Microsoft Edge
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DLP agent temp folder is filling up with .Vep files on machines that use Microsoft Edge

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Article ID: 273015

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Updated On:

Products

Data Loss Prevention Endpoint Suite Data Loss Prevention Endpoint Prevent

Issue/Introduction

DLP agent temp folder is filling up with .Vep files on machines that use Microsoft Edge. These files can take up hundreds of gigs and fill up a drive.

Note that up to 100 .vep files in this folder are normal. Beyond that number would be a concern.

Environment

16.0 / 16.0 RU1

Cause

DLP was not cleaning up some of the temporary files that Edge was triggering DLP to scan. This is believed to have been caused by a change in Edge behaviors. 

Resolution

If you are on 16.x then the recommended fix is to download 16.0 RU1 Hotfix 3 (16.0.10003) or later from the support portal.

Please contact support if you are on 15.8 and have this issue.

As a workaround, initiate a restart task from the Enforce console. As during an agent restart it cleans up the old VEP files.

Alternatively, the solution from this KB will also resolve the issue. (The solution in this article only applies to 15.8 as 7 is no longer valid for ENABLE_VEP_FILE_ELIMINATION.int in DLP 16)

DLP 16: Changing the ENABLE_VEP_FILE_ELIMINATION.int with a setting of 2 or 3 will help minimize the issue as the issue occurs when the setting being used is 0 or 1.