CALL Object does not show all USER/USERG in Recipient list
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CALL Object does not show all USER/USERG in Recipient list

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Article ID: 272982

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Updated On:

Products

CA Automic Workload Automation - Automation Engine CA Automic One Automation

Issue/Introduction

When editing a notification (CALL) object, specifically an email or html notification, the dropdown for Recipient does not show all users (USER) or usergroups (USERG) in the client.

Looking at all users, there are hundreds in the client.

Looking at the recipients list, only three show up:

Environment

Release : 21.0.5

Cause

This is caused by insufficient privileges on a particular FOLDER that houses users:

It appears that for the logged in user that is NOT getting the complete list, in the Users Authorization, there is most likely a filter that blocks a certain folder where the Users are stored.  That is why when doing an advanced search on object type user with the same (restricted) user only gets a subset of them.  

Resolution

To resolve this, the user needs to have their authorizations updated to allow browsing (READ) of the folders where the User objects are.  Once the folder browse is allowed for the folders that contain users, (folder content is displayed in Process Assembly) they will also show in the drop-down selectors.

Full reproduction steps are below:

  1. Create a folder /TICKETS/33000000_33999999/33434690
  2. Create a user, 33434690/33434690
  3. Give that user the following rights:
    1 * * RWXDCSPM
    NOT FOLDE *USER* RWXDCSPM

  4. Create the folder /USERS
  5. Put a user in there: DUMMY/DUMMY
  6. Login as user 33434690/33434690
  7. Go to /TICKETS/33000000_33999999/33434690
  8. Create a call object type mail
  9. Open the Recipients and look at the dropdown.  DUMMY/DUMMY does not show up

  10. By updating the NOT line so that it's just WXDCSPM, the user is able to see the DUMMY/DUMMY user in recipients