Clarity SaaS GCP: API Keys in Clarity stop working before expiration date
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Clarity SaaS GCP: API Keys in Clarity stop working before expiration date

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Article ID: 272936

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Updated On:

Products

Clarity PPM SaaS

Issue/Introduction

We have a scenario where API keys created in Clarity PPM stop working. We've validated the expiration date that is set and it's for a future date, so the keys didn't expire.

Environment

Release : 16.1.2, 16.1.3

Cause

We observe the following error in app-ca.log

(clarity:unknown:none:PPM_REST_API) AccessTokenAuthenticationService:: tenantId xxxx.xxxxxx doesn't match UtilityThreadLocal.getTenantId() xxxxxx

Furthermore this is only observed in Clarity PPM SaaS GCP customers.

 

Resolution

We identified the issue as DE77327 and it's fixed in 16.2 release which is the upcoming release.