Upgrade EEM from 12.6.3.0 to 12.6.6 - CA Directory installation failed
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Upgrade EEM from 12.6.3.0 to 12.6.6 - CA Directory installation failed

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Article ID: 272869

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Updated On:

Products

CA IT Asset Manager Asset Portfolio Management CA Service Management - Service Desk Manager CA Service Desk Manager CA Service Catalog

Issue/Introduction

Upgrade EEM from 12.6.3.0 to 12.6.6 - CA Directory installation fails

Error in eiam-install.log:

InstallCADirectoryAction - CA Directory installation returned 3010

Error in cadir_install.log:

Restore will not run, MsiInstallProduct failed '3010'

Environment

EEM: 12.6.6

Cause

The error message you see "CA Directory installation returned 3010" means that Windows Requires a Restart. 

Reference:

https://learn.microsoft.com/en-us/windows/win32/msi/error-codes?redirectedfrom=MSDN

 

Resolution

Restore the snapshot prior to the upgrade, restart Windows, and then try the upgrade. If no snapshot: Reboot the Windows server and then re-run the CA EEM installation.