CI Creation Generates Duplicate Primary Key Error
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CI Creation Generates Duplicate Primary Key Error

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Article ID: 272831

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

When creating a test CI the following error is generated in the GUI

 

The following error is found in the STDLOG

sqlagt:ca_owned_reso    3552 ERROR        sqlclass.c            1016 SQL Execute  failed: [Microsoft SQL Server Native Client 11.0] [ SQL Code=3621 SQL State=01000] The statement has been terminated.; [Microsoft SQL Server Native Client 11.0] [ SQL Code=2627 SQL State=23000] Violation of PRIMARY KEY constraint 'aud_ca_owned_resource_PK'. Cannot insert duplicate key in object 'dbo.aud_ca_owned_resource'. The duplicate key value is (6016705).

 

Environment

Release : 17.3.x

ITAM was previously installed in the environment, but the server was decommissioned many years ago

Cause

There are MDB triggers on the SDM table ca_owned_resource that are trying to insert the data into aud_ca_owned_resource

The primary key already exists in aud_ca_owned_resource and so this causes the creation of the CI to fail

Resolution

aud_ca_owned_resource is an ITAM table and not used by Service Desk Manager so this operation is not necessary if you are not using ITAM

In a Service Desk Manager environment without ITAM, there are no triggers present

You should be able to disable and eventually remove those triggers after testing in a non production environment first