NetOps Portal install failed with a message regarding Kafka
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NetOps Portal install failed with a message regarding Kafka

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Article ID: 272797

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Updated On:

Products

DX NetOps

Issue/Introduction

We are attempting to install the DX NetOps Portal.  The install failed after the wizard could not connect to something called Kafka. 

 

Failed to Establish Connection to Kafka
---------------------------------------

Unable to connect to Kafka Broker(s) :9092

PRESS <ENTER> TO ACCEPT THE FOLLOWING (Exit): 

Environment

All supported releases

Cause

While the "NetOps Kafka Configuration" option was answered as yes, the rest of the configuration questions were not answered with information that led to a Kafka server.

Resolution

If you do not have a Kafka server to link into, when asked the below question, answer "1- No"

 

NetOps Kafka Configuration
--------------------------

The NetOps Event Manager may be configured to produce events to kafka.  This 
requires that you have already setup one or more kafka brokers for use by 
NetOps.

Would you like to enable this configuration?

  ->1- No
    2- Yes

ENTER THE NUMBER OF THE DESIRED CHOICE, OR PRESS <ENTER> TO ACCEPT THE 
   DEFAULT: