Missing PC and sso service start.ini files after upgrading Portal
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Missing PC and sso service start.ini files after upgrading Portal

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Article ID: 272762

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Updated On:

Products

DX NetOps CA Performance Management - Usage and Administration

Issue/Introduction

Script written by a Broadcom consultant backs up the 'netqosportal' and 'em' databases, as well as SSH/SSO configurations.

Recent upgrade from 22.2.2 to 22.2.10 and MySQL 8.x for a non-prod system returned results from the script indicating missing config files. It reports these files missing.

$pc_dir/PC/start.ini (no longer present)
$pc_dir/sso/start.ini (no longer present)

Where did the DX NetOps Performance Management Portal web server start.ini files for the PC (console) and sso service go? Why are they missing?

Environment

All supported DX NetOps Performance Management Portal web server releases 22.2.7 and newer

Cause

Portal was updated to use a version of Jetty that no longer requires the use of start.ini files.

Resolution

The new Jetty web server version used in 22.2.7+ releases, Jetty 10.0.13, no longer requires the use of the start.ini files.

As a result any install or upgrade using a 22.2.7 or newer release will no longer contain start.ini files.