Unable to login to Enterprise Dashboard and Registry POD shows as Pending
search cancel

Unable to login to Enterprise Dashboard and Registry POD shows as Pending

book

Article ID: 272737

calendar_today

Updated On:

Products

Service Virtualization

Issue/Introduction

DevTest 10.7.2 Registry, Portal, VSE and other components are running in AWS EKS cluster and connecting to IAM and Enterprise Dashboard running on On-Premise Linux server.

The below error is seen in enterprisedahboard.log and users are not able to login to Enterprise Dashboard and also seen the Registry pod status as Pending. 

----------------
"ERROR com.broadcom.segment.micrometer.SegmentMetricRegistry - Exception encountered executing PublishingStrategy: No signature of method: groovy.lang.MissingMethodException.printStackTrace() is applicable for argument types: () values: []"
-----------------

Environment

Release : 10.7.2

Cause

Enterprise Dashboard ran out of memory and caused the issue.

Resolution

Giving more memory to the Enterprise Dashboard and restarting it should resolve the issue.
For example: Set the property -Xmx2048m (2gb or more) in DevTest_Home/bin/EnterpriseDashboardService.vmoptions.
 

Additional Information

In addition to increasing the memory, make sure IAM, Enterprise Dashboard and other components start with valid user.