caf not started after CU patch installation
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caf not started after CU patch installation

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Article ID: 272650

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

During installation of CU patch, caf is stopped but it is not started at the end.

Example :

In postinstall.log we could see this :

"SOURCEDIR = C:\CU6\99111823_CU6_Manager"
...
"ITCM installed location: D:\MN\CA\DSM\"
...
"Starting CAM service..."
"CAM started succesfully "
"Starting CAF service... "
"CIC is installed on this machine."

This indicates that following command was not executed

echo "Starting CAF service... "
.\bin\caf start
IF %ERRORLEVEL% EQU 0 (
    echo "Wait time 240 seconds..."

Environment

Client Automation 14.5

Cause

This problem occurs if disk for source files is not the same as disk of Client Automation installation

In example above, source files was on disk C: (C:\CU6\99111823_CU6_Manager) and ITCM installation is on disk D (D:\MN\CA\DSM\)

Resolution

In PostInstallScript.bat change the lines with cd by cd /D
 
Example for CU6 patch, change the lines #47, #221, #253 and #284 like this :
 
cd /D %ITCMINSTDIR%
cd /D "%ITCMPATH%bin\Telemetry\ItcmRestServer"
cd /D %SOURCEDIR%
cd /D %SOURCEDIR%
 
Similar thing could be done in postInstall_enc.bat (Agent patch) :
Example in CU6 patch change the line #28 like this :
 
cd /D %ITCMINSTDIR%