Unable to connect to Clarity database after upgrade
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Unable to connect to Clarity database after upgrade

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Article ID: 272479

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Updated On:

Products

Clarity PPM On Premise Clarity PPM SaaS

Issue/Introduction

After Clarity upgrade, we are unable to connect to Clarity, in CSA the database is not available and error is shown: "Unable to persist configuration properties to database. Likely cause is database properties are not yet set or misconfigured"

Environment

Release : Any

Cause

  • This happens due to the fact that during upgrade, an empty folder was specified as install.dir directory.
  • Then a new Clarity was installed and the database was not upgraded
  • Since Clarity is higher version and database is not upgraded, they will not work to connect

Resolution

You have to re-do the upgrade correctly in order to bring the database to the same level

  1. Rollback the Clarity files back to prior version
  2. Stop and remove services
  3. Start the installer and when prompted for the install.dir, please enter the directory where Clarity resides.
  4. There will then be an additional prompt for Upgrade target directory, which again you specify the same folder

This should work to correctly proceed with the upgrade and bring both Clarity and the database to the target version