Adapter shows Blocked status
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Adapter shows Blocked status

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Article ID: 272457

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Updated On:

Products

CA Business Service Insight

Issue/Introduction

Adapter is showing Blocked status and we are not able to start the adapter

Environment

Release : 8.35

Cause

Investigation into the Translation.xml file found that there were >1000 occurrences of "TranslationStatus="Pending"

Looking in ADAPTERNAMEConfig.xml and found the following setting: RejectedEventsUpperLimit="1000"

Resolution

There are three options - the first two solutions are short term fixes and the third option is a long term solution

1) Update ADAPTERConfig.xml and increase RejectedEventsUpperLimit="1000" above the number of occurrences found in Translation.xml

2) Rename output\rejectedEvents.txt to something else so the rejected event limit count starts again

3) Update the Translation Tables via the UI to map the Pending entries to valid resource IDs - https://techdocs.broadcom.com/us/en/ca-enterprise-software/business-management/clarity-business-service-insight/8-3-5/design-and-implementation/data-gathering-and-adapters/translations/translation-tables.html