IT Management Install Fails With Error: Could not obtain exclusive lock on database 'model'
search cancel

IT Management Install Fails With Error: Could not obtain exclusive lock on database 'model'

book

Article ID: 272223

calendar_today

Updated On: 04-10-2025

Products

IT Management Suite

Issue/Introduction

IT Management install fails and the Symantec Installation Manager displays the following errors:

"A critical error occurred:

"System.Reflection.TargetInvocationException: Exception has been thrown by the target of invocation. ---> System.Data.SqlClient.SqlException: Could not obtain exclusive lock on database 'model'. Retry the operation later.

"CREATE DATABASE failed. Some file names listed could not be created. Check related errors.

"Configuration failed while attempting: Configuring database..."

Environment

ITMS 8.x

Cause

A monitoring agent on the SQL server had a lock on the ‘model’ database, which caused a conflict with the installation process. 

Resolution

Disabled the monitoring agent and this removed the lock and allowed a successful installation.