Symantec Protection Engine daemon is not starting after installation on Linux Machine
search cancel

Symantec Protection Engine daemon is not starting after installation on Linux Machine

book

Article ID: 272173

calendar_today

Updated On:

Products

Protection Engine for Cloud Services Protection Engine for NAS

Issue/Introduction

Symantec Protection Engine (SPE) daemon (symcscan) is not getting started after installation of SPE on the Linux machine. 

In SymantecProtectionEngineAbortLog.txt file shows the following error 

2023/08/04-11:51:11 300 XML files did not validate : Error Validating configuration.xml. Element '/configuration/Resources/System/JavaLocation/@value' value: '/opt/binaries/jdk1.8.0_191/jre/bin/java/java' is not a valid value of the local atomic type. Error Message: Configured java does not exist. Please configure the supported version of 64 bit java(1.8 family update 232 or later version in the same series).

Environment

Symantec Protection Engine 8.2 and Higher

Linux Operating System

Cause

Java location path is incorrect/unreachable in the configuration.xml file.

Resolution

1. Navigate to /opt/SYMCScan/bin directory.

2. Add the Java path by using the following command and start the SPE service.

- ./xmlmodifier -s //Resources/System/JavaLocation/@value /<Java file path> configuration.xml

Ex. 

./xmlmodifier -s //Resources/System/JavaLocation/@value /opt/jdk1.8.0_301/bin/java configuration.xml

3. Start the SYMCscan service.

/etc/init.d/symcscan start

Additional Information

This has been seen in rare cases when using special characters such as $ within the password for the Java Key Store (JKS), which prevents the Java instance from being accessible and leads to the same log entries. Removing this special character allows the access without incident.