Basic Inventory last received information is not updated in the SMP Console
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Basic Inventory last received information is not updated in the SMP Console

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Article ID: 272134

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Updated On:

Products

IT Management Suite

Issue/Introduction

Lots of managed machines are not updating the basic inventory automatically. The managed machines sent Basic Inventory but in the SMP Console (under Manage>Computers) it shows a much older date.

Here's an example of what the SMP Console shows:

Here's an example of what the Agent (Symantec Management Agent) UI shows:

NOTE: Sometimes the date is the same but the time shows the mismatch.

Environment

ITMS 8.7

Cause

Known issue. The Symantec Management Agent (SMA) UI shows the date of any basic inventory NSE - delta or full, while the SMP Console shows the date of the last aex_ac_identification dataclass update.

Resolution

This issue was addressed in the ITMS 8.7.1 release.

A safety check was added to guarantee that full basic inventory is sent at least once per policy interval.

The new value "Basic Inventory Full Last Post" regkey under HKEY_LOCAL_MACHINE\SOFTWARE\Altiris\Altiris Agent\Servers\<server name> indicates the time of the last full basic inventory.

The old value "Basic Inventory Last Post" indicates the time of last full or delta inventory.

An updated was also made so that the SMP Console to uses the "Inv_AeX_AC_Client_Status" table for the Basic Inventory date:

The "vAC_AgentBasicInventoryHealth" view is updated and now gets information from "dbo.Inv_AeX_AC_Client_Status" instead of previous "dbo.Inv_AeX_AC_Identification".