After Migrating to new Application Server the Upgrade fails with - {Application server} not a supported version
search cancel

After Migrating to new Application Server the Upgrade fails with - {Application server} not a supported version

book

Article ID: 271982

calendar_today

Updated On:

Products

CA Identity Manager CA Identity Suite

Issue/Introduction

Upgrading from older IM where original IM was installed into different app server location then it currently is in (i.e. migrated from Wildfly 15 folder to Wildfly 23 folder) results in the upgrade installer failing.

An error such as:

BUILD FAILED
\installFragments\build.xml:651: The following error occurred while executing this line:
\installFragments\taskEngine.xml:2568: C:\wildfly-15.0.1 is not a supported version.

will appear in the \IAM Suite\Identity Manager\caiamsuite.log file. 


installer may say is completed successfully but then the initial startup and deployment of the iam_im.ear does not appear to upgraded or deployed correctly. 

Environment

Identity Manager 14.4, 14.5

Cause

The migration utility is not able to update Broadcom files, so the Server-location.cmd/sh, and Server-location.cmd/sh will hold the older Application server location information causing the upgrade to confuse the old and the new Application Server paths. 

 

Resolution

This is discussed in the Before You Upgrade section of the Documentation.

Review the two files:

<Identity_Manager_Install_DIR>\install_config_info\Server-location.cmd/sh
<Identity_Manager_Install_DIR>\IAM Suite\Identity Manager\install_config_info\Server-location.cmd/sh

Search for any older incorrect pathing or version details and update those lines with the correct Application Server installation path before performing the upgrade.