Windows System Assessment Scan not successful: WSAS' completed. Exit code=255.
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Windows System Assessment Scan not successful: WSAS' completed. Exit code=255.

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Article ID: 271887

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Updated On:

Products

Patch Management Solution Patch Management Solution for Servers

Issue/Introduction

After upgrading around 1000 machines to ITMS 8.7 it was noticed that less than 20 machines failed to run the Windows System Assessment Scan (WSAS) successfully and the only helpful entries in the agent logs are:

Severity: 4
Date: 4/14/2023 12:00:00 PM
Tick Count: 92087312
Host Name: <Hostname>
Process: AeXNSAgent.exe (17268)
Thread: 21972
Module: smfagent.dll
Source: ProgramExec
Description: 
  Starting SWD task: 'PAE - WSAS' command line='"C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\{6D417916-467C-46A7-A870-6D86D9345B61}\cache\RunAssessment.bat" -diff'  working directory = 'C:\Program Files\Altiris\Altiris Agent\Agents\SoftwareManagement\Software Delivery\{6D417916-467C-46A7-A870-6D86D9345B61}\cache'

Severity: 4
Date: 4/14/2023 12:00:01 PM
Tick Count: 92088187
Host Name: <Hostname>
Process: AeXNSAgent.exe (17268)
Thread: 21972
Module: smfagent.dll
Source: ProgramExec
Description: 
  Program 'PAE - WSAS' completed. Exit code=255. Execution context='Administrator'. RunAs='\'

Confirmed that the number of machines affected was just 2-3% of those in the environment by using the Windows System Assessment Scan Summary report found in the SMP Console under:

Reports > Software > Patch Management > Diagnostics > Windows System Assessment Scan Summary

The Microsoft  Exit code=255 seen in the agent.log files is informational a Google search implies that this may be permissions related.  The AppID permission or Agent Connectivity Credential permissions are used depending on the Notification Server configuration.  The following KB provides guidance on this (but again only 2% or so of the machines were having this issue):

194234 How to setup Agent Connectivity Credential (ACC) and Best Practices

Verified the following and these didn't help:

  • Check to see if the AV software on these machines might be misbehaving and resolve this (remove the AV software completely while testing, or uninstall/reinstall it)
  • Check to see if any of the affected machines have any hardening software on them
  • Checked the Event Viewer logs and nothing helpful was found
  • Checked to see if one or two machines could be reimaged to see if this might help and found that they were servers so this wasn't an option
  • Uninstall/Reinstall the Sym Agent and the same issue existed
  • Verified that the permissions are the same on the working machines and those having this issue
  • Confirmed it was not a certificate issue

Environment

ITMS 8.x

Cause

When running WSAS run through a Policy it fails for some reason on a few machines and it always works for these machines when run from a Task.  

Resolution

The workaround was to create a Task to run WSAS on a schedule and target the few affected machines or use the following Task:

Managed > System Jobs and Tasks > Software > Patch Management > Run System Assessment Scan on Windows Computers