Connectivity error with Oracle Server while installing 17.3.0.22 patch
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Connectivity error with Oracle Server while installing 17.3.0.22 patch

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Article ID: 271876

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Updated On:

Products

CA Service Desk Manager CA Service Management - Service Desk Manager

Issue/Introduction

Tried to update our TEST environment to CA SDM 17.3.0.22 and while following the steps in the installer we got the next error:

The connection with the Oracle Database Server can't be established

Error is seen during the installation interview on the Database configuration

The thing is that the details are correct, and are exactly the same we provide when we execute 'pdm_configure' command (pdm_configure works fine).

We tried to execute the patch in another environment (TEST2 environment) and the connectivity check with the Oracle server was correct.

The difference between both environments is:
-TEST environment: Oracle 12 client (32 and 64) connect to Oracle 19 Database
-TEST2 environment: Oracle 12 clients (32 and 64) connect to Oracle 12 Database.

Is that a problem form the patch installer? Why the patch installer can't connect to the Oracle Server but the 'pdm_configure' with the same details can?

Environment

Release : 17.3

Cause

the error was produced because the listener didn't know the service name

Resolution

Corrected the listener and the database connectivity check finished correctly.

Additional Information

One can review the stdout.txt and stderr.txt files that are written to the root of the install drive, usually C:\.  These files are created in realtime during the installation run and may contain information on the errors experienced during the interview segment of the install run.