CAU for Agent behind Proxy component
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CAU for Agent behind Proxy component

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Article ID: 271761

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Centralized Agent Upgrade (CAU) applied to non-TLS Agents connecting to the Automation Engine (AE) via a Proxy application fails.

Reason: During the CAU process the certificate of the JCP is pushed to the Agent. However, the agent connects the version 21 Proxy Server, the certificate of the Proxy Server is required to establish a successful WebSocket connection. That is why CAU aborts.

Environment

Release : AE and Poxy Server and CAU 21.0.5

Cause

The technical reason for this problem is explained in the Introduction part.

Resolution

This was stated as a Product limitation by Product Management, and changed in Version 21.0.7 of the Engine:

A problem with CAU in version 12.3 for Agents behind a PROXY has been solved.

In case of upgrading a GSS agent to a TLS/SSL agent using CAU, the new parameter "connection" is taken from the system setting JCP_ENDPOINT and added to the agent ini file.

This specific connection string can now be overwritten by setting the system setting JCP_ENDPOINT_CAU_OVERRIDE.

This is now documented here

 

Additional Information

R&D ticket ID: AE-31501

R&D ticket title: CAU for Agent behind Proxy component.

https://docs.automic.com/documentation/webhelp/english/ALL/components/DOCU/21.0.7/Automic%20Automation%20Guides/Content/Installation_Upgrade/install_CAU.htm?Highlight=cau