VSE recorder processing response as binary, when Accept-Encoding header is gzip.
search cancel

VSE recorder processing response as binary, when Accept-Encoding header is gzip.

book

Article ID: 271717

calendar_today

Updated On:

Products

Service Virtualization

Issue/Introduction

We are having issues where VSE recorder is not processing the response correctly after 10.7.2 upgrade. We have JSON request/response format. I tried from the Portal

We have a Request Header that we send to live system

Accept-Encoding: gzip,deflate 

 

When we try to record this transaction , the VSE recorder captures the response as binary. 

Environment

Release : 10.7.2

Cause

Parsing Request and Response with Metadata arguments containing "encoding"

Resolution

 We have a fix for the VSE recorder encoding issue : patch_DE573967_10.7.2_GA.jar.

Please open a ticket with Broadcom Support for the patch. 


1. NOTE: The patch is mainly meant for recording HTTP Virtual services. The patch can be applied to Workstation and VSE servers
2. Place the patch file "patch_DE573967_10.7.2_GA.jar" at LISA_HOME/lib/patches folder
3. Restart the services and workstation
4. Record a virtual service as before and confirm if the reported problem has been addressed.