Agents continually resetting GUIDs
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Agents continually resetting GUIDs

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Article ID: 271514

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Updated On:

Products

Client Management Suite

Issue/Introduction

You have several machines in just ONE location that are resetting GUIDs continuously.  These machines seem to have duplicate GUIDs.

You have uninstalled and reinstalled the Altiris Agent (as well as cleaning the registry) on three different machines and this is still happening.  

 

NS logs show:

Host Resource <GUID of Computer> shares GUID with another machine: HOSTNAME.domain.COM. The resource must change its GUID

Add duplicate computer resources to the blacklisted hosts' list 

 

 

Environment

Release: 8.7

Cause

Preconfigured MDM registry setting on newly added computers causing merging based on wmdm_device_id resource key.

The "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Provisioning\OMADM\MDMDeviceID" key is a unique Mobile Device Management (MDM) device identifier. It is expected to be different for each device.

 

Resolution

Delete HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Provisioning\OMADM\MDMDeviceID on devices in the newly added site/location. 

Make sure to review your imaging process to ensure a clean, un-enrolled image is deployed without MDMDeviceID key. After deploying the image, they may re-enroll the device to generate a unique MDM identifier.