Package is "Ready" on Package Server but not in Database Altiris\Altiris Agent\Queue
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Package is "Ready" on Package Server but not in Database Altiris\Altiris Agent\Queue

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Article ID: 271498

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Updated On:

Products

IT Management Suite

Issue/Introduction

Need to distribute an important image file and the Site Servers (Package Servers) have downloaded the image and show it as ready, but the database still shows as Not Ready in the SMP Console.

Environment

ITMS 8.6

Cause

The Altiris\Altiris Agent\Queue\SMPServerName folder is backed up with thousands of unprocessed NSE files.

Resolution

When a package server is unable to download a package, it will retry that download.  Every time it does this, an NSE is sent up to the SMP server indicating this information.  When you have many packages that are stuck in a retrying download scenario, many NSEs will be generated.  If something else happens on the SMP server causing a backup, the local Altiris\Altiris Agent\Queue\SMPServerName folder can get backed up to the point there are too many unprocessed NSE files.

Stop the Symantec Management Agent service and manually delete the file in the Altiris\Altiris Agent\Queue\SMPServerName folder.  Start the Symantec Management Agent Service and watch this folder.  You will see a few NSEs populate, but they should quickly go away.

Monitor this folder for possible backup and identify what the root cause could be.