Error when creating a PUSH subscription in Spectrum
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Error when creating a PUSH subscription in Spectrum

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Article ID: 271098

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Updated On:

Products

DX NetOps CA Spectrum

Issue/Introduction

We have created a PUSH alarm subscription in Spectrum to PUSH the alarms to another web server. The subscription gets created successfully. However, when we check the subscription, we are seeing the following:

UUID=446086ec-a2d4-4b54-8cd4-220bfd718a0e, subscription=Subscription 446086ec-a2d4-4b54-8cd4-220bfd718a0e<br />  Heartbeat Interval: 600000<br />  Delivery Mode: BATCHED_PUSH<br />  Destination URL: http://www.<hostname>.<yourdomain>.com<br />  Media Type: application/xml;charset=UTF-8<br />  Batched Notification Interval: 1000<br />  Max Batched Notifications: 100<br />  Queued Notifications: 0<br />  Batch Timer Task is  running<br />  Delivery Failure Count: 0<br />  Failed Notifications: 1493<br /><br />  AlarmSubscriber<br />    Requested Attr IDs: {0x11f56,0x12b4c,0x1006e,0x11f4e,0x1296e}<br />    Filter: null<br /><br /><br /><br />.... Spectrum]

As highlighted above, the "Failed Notifications" increase and nothing is written to our web server.

We enabled the RESTful Web Services debugging in the OneClick Administration -> Debugging -> Web Server Debug Page (Runtime) page and see the following in the tomcat log file ($SPECROOT/tomcat/logs/stdoout.log for Windows or catalina.out file for Linux):

Jul 31, 2023 21:01:39.406 (PoolThread-20: Subscription afc58a1e-e8ff-4867-9d5c-b3cda90d3c28 => SubscriptionManager.sendNotificationList afc58a1e-e8ff-4867-9d5c-b3cda90d3c28) (RESTFULWEBSERVICES) - (DEBUG) - Error delivering notifications to destination http://www.<hostname>.<yourdomain>.com with subscription ID afc58a1e-e8ff-4867-9d5c-b3cda90d3c28: java.net.ConnectException: Connection refused (Connection refused)

Environment

Release : Any
Component: Rest API

Cause

Possible root causes:

- Incorrect username and/or password for the target web server

- Incorrect http or https port of the target webserver used in the subscription

- Wrong interface ip set on the target web server

Resolution

- Verify the username and/or password are correct for the target web server in the subscription.

- Verify you are using the correct http or https port for the target web server in the subscription

- Verify the ip address set on the target web server.