Getting error "PAM-CMN-0900: Bad User ID or Password" when trying to connect via the CA PAM Mac Client
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Getting error "PAM-CMN-0900: Bad User ID or Password" when trying to connect via the CA PAM Mac Client

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Article ID: 270970

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Updated On:

Products

CA Privileged Access Manager (PAM)

Issue/Introduction

After upgrade to PAM 4.1.3, users on macOS get this error when trying to connect to PAM through the Client:

 

Environment

CA PAM 4.1.3

Cause

This is caused by the language settings not being picked up correctly by the CA PAM Client, thus leading to incorrect mappings of some keys in the context of non-English keyboards

Therefore, when there is some entry which is in different places in the en-US keyboard and the one corresponding to the localized version of Mac OS that the client is running on, there will be characters which will be incorrectly passed and the password will be wrong

Resolution

Uncheck the Autodetect checkbox for the CA PAM Client language settings in its Configuration/General tab