NetOps Portal or Data Aggregator is not accessible after updating HTTPS certs
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NetOps Portal or Data Aggregator is not accessible after updating HTTPS certs

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Article ID: 270908

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Updated On:

Products

DX NetOps CA Performance Management - Usage and Administration

Issue/Introduction

NetOps Portal is not accessible after updating HTTPS certs.

Data Aggregator is not accessible after updating HTTPS certs.

Environment

All supported releases

Cause

When doing the import command, the -file contained a cert that was the root, intermediate, and server certificate, so it was accepted.  The problem that can happen is if the root and intermediate are not in the paired cacerts/truststore, services will not start.  When trying to import JUST the server certificate into keystore, the following error is displayed:

keytool error: java.lang.Exception: Failed to establish chain from reply  

 

Resolution

Manually import the root and intermediate into the related truststore/cacerts:

Note: the root calls should prompt a message asking to trust the cert, whereas if done after the root calls, the intermediate calls should NOT ask to trust.  If they do, you likely have an issue with your certificates.

Portal:

  1. /opt/CA/jre/bin/keytool -import -cacerts -alias root -file root.cer   
  2. /opt/CA/jre/bin/keytool -import -cacerts -alias intermediate -file intermediate.cer 

DA:

  1. /opt/IMDataAggregator/jre/bin/keytool -importcert -keystore /opt/IMDataAggregator/apache-karaf/etc/truststore -alias root -file root.cer
  2. /opt/IMDataAggregator/jre/bin/keytool -importcert  -keystore /opt/IMDataAggregator/apache-karaf/etc/keystore -alias intermediate
  3. /opt/IMDataAggregator/jre/bin/keytool -importcert -cacerts -alias root -file root.cer
  4. /opt/IMDataAggregator/jre/bin/keytool -importcert -cacerts -alias intermediate -file intermediate.cer