"Failed to initialize ICFEencryt instance. [CMG000005]" error occurs while opening the DSM Explorer.
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"Failed to initialize ICFEencryt instance. [CMG000005]" error occurs while opening the DSM Explorer.

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Article ID: 27090

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Updated On:

Products

CA Client Automation - IT Client Manager CA Client Automation

Issue/Introduction

While opening DSM Explorer, the following error occurs: "Failed to initialize ICFEencryt instance. [CMG000005]"

Environment

Client Automation - All versions

Cause

When the DSM Explorer is opened, a localid key is calculated using the MAC Address, serial number and computer name. This calculated localid is compared with the value stored in the comstore under the section ITRM/CFENCRYPT/LOCALID. If the value is different, the DSM Explorer updates the comstore with the new calculated value.

When the DSM Explorer is opened with a user which does not belong to the Local Administrators group, it cannot update the comstore because a non-administrative user does not have write permissions on the comstore and the error "Failed to initialize ICFEncrypt instance. [CMG000005]" occurs.

Note: The Localid key is calculated from system parameters like volume serial number, MAC address, and computer name. So if nothing is changed in the system, the LOCALID key should not be changed.

Resolution

  1. Logon to the machine with the problem DSM Explorer using an Administrator account.

  2. Stop CAF service using:
    caf stop

  3. Run the following command:
    ccnfcmda -cmd DeleteParameter -ps itrm/cfencrypt -pn LOCALID

  4. Start the CAF service using:
    caf start

Additional Information

Sometimes the problem may occur due to the order of the Network cards not being the same for different users.

If the above solution does not work, change the order of the network card as below:

  1. Logon to the machine with the user account, which encounters the above error.

  2. Open Control Panel and switch to 'Classic View' and double click on 'Network Connections'.

  3. In the Advanced menu, select 'Advanced settings'.

  4. In the 'Advanced Settings' dialog box, go to the "Adapters and Bindings" tab.

  5. In the Connections list, select the active Network card and click on the up-arrow button to put it first in the list.

  6. Click OK to save the modifications.